ICE has informed that "Progress has been made to process the backlog of Encompass Partner Connect orders. The backlog of orders has begun processing and this should be reflected within the application as they complete. There will be delays on processing the entire backlog, but processing will complete."
We are seeing successful transactions and will continue monitoring.
Posted Jul 30, 2026 - 15:49 EDT
Monitoring
We have been seeing transactions successfully process through EPC for the affected products since approximately 1:45 PM EDT. This indicates that services are recovering. We will continue to closely monitor transaction processing and provide additional updates as needed.
Posted Jul 30, 2026 - 14:24 EDT
Update
ICE has informed that "Core services are returned to normal operation & remain stable. Our current focus is restoring our Encompass Partner Network & ICE PPE services. This is a critical priority & we will post an update as status changes."
We will keep you updated.
Posted Jul 30, 2026 - 13:55 EDT
Investigating
IR Platform is currently experiencing connectivity issues with Encompass Partner Connect. ICE has confirmed a service disruption impacting all orders and are working currently on it. IR platform is still accepting requests through our portal and other interfaces.
Posted Jul 30, 2026 - 13:19 EDT
This incident affected: Credit Monitoring (Experian, TransUnion, Equifax), Verification of Income, Employment and Assets (AccountChek Verification of Assets, AccountChek VOIE, AccountChek Customer Test Environment, Experian Verify, Income Tax Verification, The Work Number Instant VOE/I, The Work Number Manual VOE/I, Veri-Tax), and Other (Flood, Social Security Administration).