Report: Issues with handling Experian Credit Report orders

Incident Report for Informative Research

Resolved

Connection looks stable and no issues are observed in the last hour.
Posted Oct 29, 2025 - 18:22 EDT

Identified

We are currently experiencing intermittent connectivity issues with XPN, which are affecting a small number of orders.

XPN has confirmed they are aware of the issue and are actively working to resolve it.
Posted Oct 29, 2025 - 16:47 EDT
This incident affected: Credit Reports (Experian Data Connection).