TU has delivered files for PCM orders ordered till 11/16, and those orders have been successfully processed. TU is working on orders placed on 11/17 and later, which are yet to be received and processed on our end.
Posted Nov 20, 2025 - 10:31 EST
Update
TU has delivered files for PCM orders ordered on 11/12 and 11/13, and those orders have been successfully processed. However, TU is still working through a backlog of orders placed on 11/14 and later, which are yet to be received and processed on our end.
TU is actively working on resolving the issue and completing the processing of the remaining backlog orders.
Posted Nov 19, 2025 - 10:33 EST
Monitoring
All TU PCM orders ordered since 11/12 are have not yet been processed. TU has confirmed that there is a delay on their side and they are working actively on delivering the files soon.
Posted Nov 17, 2025 - 12:45 EST
This incident affects: Credit Monitoring (TransUnion).