Equifax Outage

Incident Report for Informative Research

Resolved

Equifax has confirmed that issue has been resolved.

Transactions are going through successfully since last hour.
Posted Jul 07, 2025 - 23:49 EDT

Monitoring

Equifax connectivity has been successfully restored, and transactions have been processing without issues for the past 30 minutes.
Posted Jul 07, 2025 - 23:08 EDT

Identified

Equifax is currently experiencing connectivity issues since 5:10 pm (PST).

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Jul 07, 2025 - 20:32 EDT
This incident affected: Credit Reports (Equifax Data Connection).