TransUnion Outage

Incident Report for Informative Research

Resolved

TU connectivity issue appear to be resolved. No partial delivered orders after 9:00 AM PST.

Since the connection is stable, marking this incident as resolved
Posted Mar 07, 2026 - 14:19 EST

Monitoring

Transactions are looking stable. No partial delivery orders after 9:00 AM PST. We will continue to monitor the transactions.
Posted Mar 07, 2026 - 13:33 EST

Identified

Attempted to contact TU via phone but were unable to get connected. An email was sent to TU and Incident# 10575915 has been opened. Currently awaiting an update from TU.
Posted Mar 07, 2026 - 11:13 EST

Investigating

TransUnion is currently experiencing connectivity issues since 06:28 AM (PST).
We are trying to reach out TU team regarding this.
Posted Mar 07, 2026 - 10:23 EST
This incident affected: Credit Reports (TransUnion Data Connection).