Completed
The scheduled maintenance has been completed.
Posted Jun 27, 2025 - 22:30 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2025 - 22:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 24, 2025 - 10:11 EDT
Scheduled
We will be performing scheduled system maintenance during this window. We estimate about 15 minutes of downtime while this work is completed.
All services will resume normal operation as soon as maintenance is complete.
We appreciate your understanding and will post updates here if anything changes.
Posted Jun 23, 2025 - 10:38 EDT
This scheduled maintenance affected: Credit Reports (Experian Data Connection, TransUnion Data Connection, Equifax Data Connection), Credit Monitoring (Experian, TransUnion, Equifax), Verification of Income and Employment (AccountChek Verification of Assets, AccountChek VOIE, Experian Verify, Income Tax Verification, The Work Number Instant VOE/I, The Work Number Manual VOE/I, Veri-Tax), Integrations (GSEs), Other (BlackKnight AVM, Click2Chat, Flood, Fraud, Phone System, Social Security Administration, L&J), IR Credit Platform, and Websites (Action Center, Rescore Express, Supplement Express, Web Credit System, Verification Platform).