XPN PCM - delayed file processing

Incident Report for Informative Research

Update

We are continuing to investigate this issue.
Posted Jun 05, 2026 - 19:15 EDT

Update

XPN is still actively working on resolving the issue. No further update has been received from them yet.
Posted Jun 05, 2026 - 15:47 EDT

Investigating

All XPN PCM orders submitted since 06/03 have not yet been processed. XPN is currently investigating the issue and working actively on delivering the files soon.
Posted Jun 05, 2026 - 13:11 EDT
This incident affects: Credit Monitoring (Experian).