TransUnion Outage

Incident Report for Informative Research

Resolved

TransUnion has resolved the connectivity issues and they’re now operating normally since 10:36 AM (PST). We recommend refreshing reports affected by the outage.
Posted Feb 20, 2026 - 15:29 EST

Monitoring

TransUnion connectivity has been restored, and transactions have been processing without issues for the past 20 minutes.
Posted Feb 20, 2026 - 14:00 EST

Investigating

TransUnion is currently experiencing connectivity issues since 10:17 AM (PST).

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Feb 20, 2026 - 13:39 EST
This incident affected: Credit Reports (TransUnion Data Connection) and Credit Monitoring (TransUnion).