AccountChek EPC Disruption

Incident Report for Informative Research

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 23:36 EST

Update

We are continuing to investigate this issue.
Posted Feb 02, 2026 - 20:13 EST

Update

We are continuing to investigate this issue.
Posted Feb 02, 2026 - 19:12 EST

Update

We are continuing to investigate this issue.
Posted Feb 02, 2026 - 17:54 EST

Investigating

We are currently investigating an issue impacting AccountChek. Users may be unable to access AccountChek via Encompass Partner Connect. Our team is actively working to identify the cause and restore normal service. We will provide an update as more information becomes available.
Posted Feb 02, 2026 - 10:01 EST
This incident affected: Verification of Income and Employment (AccountChek Verification of Assets, AccountChek VOIE).