Connection has been restored, system is up and running from 4:10 PM.
Posted Jan 08, 2026 - 19:44 EST
Update
We have identified the issue causing service disruption. Our technical team is actively working to restore services as quickly as possible. We will provide further updates as more information becomes available. Thank you for your patience.
Posted Jan 08, 2026 - 19:04 EST
Investigating
We are currently experiencing a system-wide outage, and all services are temporarily unavailable. Our team is actively investigating the issue and working to restore functionality as quickly as possible. We will provide updates as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Jan 08, 2026 - 18:37 EST
This incident affected: Credit Reports (Experian Data Connection, TransUnion Data Connection, Equifax Data Connection), Credit Monitoring (Experian, TransUnion, Equifax), Integrations (GSEs), Other (BlackKnight AVM, Click2Chat, Flood, Fraud, Phone System, Social Security Administration, L&J, CreditXpert), IR Credit Platform, Websites (Action Center, Rescore Express, Supplement Express, Web Credit System, Verification Platform), and Verification of Income and Employment (Experian Verify, Income Tax Verification, The Work Number Instant VOE/I, The Work Number Manual VOE/I, Veri-Tax).