VW TWN Outage

Incident Report for Informative Research

Resolved

All transactions have been going through successfully.
Posted Mar 03, 2026 - 14:01 EST

Monitoring

Connectivity issue with The Work Number has been resolved as of 09:34 AM PT.

We are now observing TWN transactions processing successfully.
Posted Mar 03, 2026 - 12:53 EST

Investigating

IR connectivity with The Work Number is currently experiencing connectivity issues since 8:00 AM(PT).

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Mar 03, 2026 - 12:00 EST
This incident affected: Verification of Income, Employment and Assets (The Work Number Instant VOE/I, The Work Number Manual VOE/I).