Equifax Outage

Incident Report for Informative Research

Resolved

We have monitored and can confirm that TWN EFX is looking stable.
Posted Jun 12, 2025 - 18:53 EDT

Update

EFX TWN transactions have been processing smoothly for the past 30 minutes. We will continue to closely monitor the traffic to ensure stability.
Posted Jun 12, 2025 - 17:20 EDT

Update

We are noticing EFX TWN transactions failing in last 15 minutes.

IT team is actively monitoring and will provide an update as soon as the transactions are processing smoothly again. We appreciate your patience and understanding.
Posted Jun 12, 2025 - 15:19 EDT

Monitoring

Transactions have been processing smoothly for the past 20 minutes. We will continue to closely monitor the traffic to ensure stability.
Posted Jun 12, 2025 - 15:10 EDT

Update

We have been informed by Equifax (EFX) that they are currently experiencing technical issues on their end.

As a result, users may be unable to generate Preclose Credit Reports during this outage. We are closely monitoring the situation and will keep you updated as soon as we receive more information or a resolution.

We apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jun 12, 2025 - 14:36 EDT

Identified

Equifax is currently experiencing connectivity issues since 11:05 AM PST.

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Jun 12, 2025 - 14:26 EDT
This incident affected: Credit Reports (Equifax Data Connection) and Verification of Income and Employment (The Work Number Instant VOE/I, The Work Number Manual VOE/I).