Experian Credit Connectivity Issues

Incident Report for Informative Research

Resolved

We have confirmed that connectivity with Experian is now stable. All transactions are going through successfully.
Posted Jun 04, 2025 - 20:10 EDT

Monitoring

XPN connectivity has improved and errors have largely stopped over the past 10 minutes. We are still were seeing some intermittent connectivity issues that may impact certain orders and will continue monitoring over the next few hours as the situation develops.
Posted Jun 04, 2025 - 18:25 EDT

Identified

Experian is currently experiencing connectivity issues since 2:00 pm (PT).

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Jun 04, 2025 - 17:40 EDT
This incident affected: Credit Reports (Experian Data Connection).