Experian Outage

Incident Report for Informative Research

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 19:23 EDT

Monitoring

We are noticing connectivity has been restored and transactions going through since 2:32 PM PST
Posted Apr 22, 2026 - 17:44 EDT

Identified

Experian is currently experiencing connectivity issues since 1:50 pm (PST).

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Apr 22, 2026 - 17:17 EDT
This incident affected: Credit Reports (Experian Data Connection) and IR Credit Platform.