VW TWN Outage

Incident Report for Informative Research

Resolved

All transactions have been going through successfully.
Posted Jun 04, 2025 - 07:21 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 03, 2025 - 23:33 EDT

Monitoring

Connectivity issue with The Work Number has been resolved as of 11:05 PM ET.

We are now observing TWN transactions processing successfully.
Posted Jun 03, 2025 - 23:32 EDT

Update

IR Support team has reached out to the EFX Support team regarding the connectivity issue.
We are currently awaiting further updates from their end.

We will keep you informed as soon as we receive any new information. Thank you for your patience.
Posted Jun 03, 2025 - 23:08 EDT

Identified

IR connectivity with The Work Number is currently experiencing connectivity issues since 8:45 pm (ET).

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Jun 03, 2025 - 21:17 EDT
This incident affected: Verification of Income and Employment (The Work Number Instant VOE/I, The Work Number Manual VOE/I).