Unable to connect to XPN PCM SFTP

Incident Report for Informative Research

Resolved

IR connection with XPN PCM site has been restored. All alert files for previous day has been downloaded and processed successfully.
Posted Sep 18, 2025 - 13:18 EDT

Investigating

Our system is currently unable to connect to the Experian PCM SFTP environment in Production. This is preventing us from downloading and uploading new files to SFTP. PCM XPN orders placed yesterday are not submitted yet.
IT team is actively investigating the connectivity issue with Experian.
Posted Sep 18, 2025 - 12:04 EDT
This incident affected: Credit Monitoring (Experian).