Unable to connect to EFX PCM SFTP

Incident Report for Informative Research

Resolved

IR connection with EFX PCM site has been restored. All the new files has been submitted to bureau successfully.
Posted Dec 05, 2025 - 12:35 EST

Identified

Our system is currently unable to connect to the Equifax PCM SFTP environment in Production. This is preventing us from uploading new files to SFTP. PCM EFX orders placed for last couple of days are not submitted yet.
EFX team had confirmed they are having issues on their end and they are actively working on it. IT team is actively working on the connectivity issue with Equifax.
Posted Dec 04, 2025 - 11:33 EST
This incident affected: Credit Monitoring (Equifax).