Equifax – Intermittent Order Timeouts

Incident Report for Informative Research

Resolved

EFX connectivity is looking stable and we are no longer seeing connection timeouts.
Posted Aug 14, 2026 - 19:49 EDT

Monitoring

From past 30 minutes, we are not seeing any orders having Equifax connectivity issues. All orders are processed successfully.
Posted Aug 14, 2026 - 18:49 EDT

Identified

Equifax is currently experiencing connectivity issues since 5:00 pm (ET). EFX orders are intermittently timing out.

We'll inform you immediately once they resolve the issue and the connection is secured again.
Posted Aug 14, 2026 - 17:43 EDT
This incident affected: Credit Reports (Equifax Data Connection).